aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-junit-xml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-junit-xml/APKBUILD')
-rw-r--r--testing/py3-junit-xml/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-junit-xml/APKBUILD b/testing/py3-junit-xml/APKBUILD
index fe84402f5d0..4136d13b9de 100644
--- a/testing/py3-junit-xml/APKBUILD
+++ b/testing/py3-junit-xml/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinx.org>
pkgname=py3-junit-xml
_pkgname=junit-xml
-pkgver=1.8
-pkgrel=5
+pkgver=1.9
+pkgrel=2
pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
options="!check" # 1 test fail
-url="https://pypi.python.org/pypi/junit-xml"
+url="https://pypi.org/project/junit-xml"
arch="noarch"
license="MIT"
depends="py3-six"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -23,7 +24,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz"
+sha512sums="
+2a8135255f649cf1ffe0fb580ea80cec1f00e6276ebb0cbc28feda64a8c788102f5b4b65a555b451b0e9b137118baaccb014ab86be0fa30fb6829d0734226619 junit-xml-1.9.tar.gz
+"