aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-jwcrypto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-jwcrypto/APKBUILD')
-rw-r--r--testing/py3-jwcrypto/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py3-jwcrypto/APKBUILD b/testing/py3-jwcrypto/APKBUILD
deleted file mode 100644
index c4f405fc020..00000000000
--- a/testing/py3-jwcrypto/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: prspkt <prspkt@protonmail.com>
-# Maintainer: prspkt <prspkt@protonmail.com>
-pkgname=py3-jwcrypto
-_pkgname=jwcrypto
-pkgver=0.8
-pkgrel=1
-pkgdesc="Python module implementing JOSE Web standards"
-url="https://github.com/latchset/jwcrypto"
-arch="noarch"
-license="LGPL-3.0-only"
-depends="py3-cryptography"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-subpackages="$pkgname-doc"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"/$_pkgname
- py.test-3
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="e8dc62d6159e5722a572e049c41edc8e31fe0d022aa47987ab6720c7057cbac2f98cec5d35af1ea02f6bc6efde769810fde4b868e019956b138cfac529cc027d jwcrypto-0.8.tar.gz"