aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-kazoo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-kazoo/APKBUILD')
-rw-r--r--testing/py3-kazoo/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-kazoo/APKBUILD b/testing/py3-kazoo/APKBUILD
new file mode 100644
index 00000000000..eecdfaa344d
--- /dev/null
+++ b/testing/py3-kazoo/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Alex Yam <alex@alexyam.com>
+# Maintainer: Alex Yam <alex@alexyam.com>
+pkgname=py3-kazoo
+pkgver=0_git20211202
+_gitrev=f585d605eea0a37a08aae95a8cc259b80da2ecf0 # tag/rel is 16 months behind
+pkgrel=3
+pkgdesc="Python library for Apache Zookeeper"
+url="https://github.com/python-zk/kazoo"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+options="!check" # test requires zookeeper server
+subpackages="$pkgname-pyc"
+source="$pkgname-$_gitrev.tar.gz::https://github.com/python-zk/kazoo/archive/$_gitrev.tar.gz"
+builddir="$srcdir/kazoo-$_gitrev"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="
+70b3065ff5b1d119fa32937843c20dce3a355db53980c85168b2b654edb846b917ab3a612e22c0ce99e1f2d79579d90dc6252889323255b16c2ce0a6b8b1f2a1 py3-kazoo-f585d605eea0a37a08aae95a8cc259b80da2ecf0.tar.gz
+"