aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-kikit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-kikit/APKBUILD')
-rw-r--r--testing/py3-kikit/APKBUILD49
1 files changed, 37 insertions, 12 deletions
diff --git a/testing/py3-kikit/APKBUILD b/testing/py3-kikit/APKBUILD
index 73b98678b74..d7330d690ca 100644
--- a/testing/py3-kikit/APKBUILD
+++ b/testing/py3-kikit/APKBUILD
@@ -1,38 +1,63 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-kikit
-pkgver=1.0.2
+pkgver=1.5.1
pkgrel=0
pkgdesc="Python library and CLI tool to automate several tasks in KiCAD"
url="https://github.com/yaqwsx/KiKit"
-# mips, mips64, s390x: py3-shapely
-# aarch64, armv7, armhf, mips, mips64: py3-solidpython
-arch="noarch !mips !mips64 !s390x !aarch64 !armv7 !armhf"
+# riscv64: py3-shapely
+# aarch64, armv7, armhf, mips64: py3-solidpython
+# s390x: kicad
+arch="noarch !riscv64 !aarch64 !armv7 !armhf !s390x"
license="MIT"
depends="
- python3
+ kicad
py3-click
+ py3-commentjson
py3-markdown2
+ py3-pcbnewtransition
py3-pybars3
py3-shapely
py3-solidpython
+ python3
+ "
+makedepends="
+ py3-gpep517
py3-python-versioneer
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/yaqwsx/KiKit/archive/v$pkgver.tar.gz
"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/yaqwsx/KiKit/archive/v$pkgver.tar.gz"
builddir="$srcdir/KiKit-$pkgver"
-options="!check" # Not all dependencies packaged for check
+
+prepare() {
+ default_prepare
+
+ # unvendor old versioneer
+ rm -f versioneer.py
+}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ cd test/units
+ ../../.testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
+
sha512sums="
-404fecf3e89d7398159a1c63f4996fd8f8175ca55c7509994948a7e09d398e1836b5ad453c67cac0fcf7f10f0c1ad43cfccbb6c487d6b2732bbae2ed15910061 py3-kikit-1.0.2.tar.gz
+1090211f1840ebb6f2f0533b3f588405b5eb007cca6d391183e0450361f55631912891c2e25768431dc4ae0e79025313752d72e00fd049ee9e48b10cf470fcac py3-kikit-1.5.1.tar.gz
"