aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-kikit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-kikit/APKBUILD')
-rw-r--r--testing/py3-kikit/APKBUILD47
1 files changed, 35 insertions, 12 deletions
diff --git a/testing/py3-kikit/APKBUILD b/testing/py3-kikit/APKBUILD
index 6274805df5a..929b84c7383 100644
--- a/testing/py3-kikit/APKBUILD
+++ b/testing/py3-kikit/APKBUILD
@@ -1,36 +1,59 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-kikit
-pkgver=0.7
+pkgver=1.2.0
pkgrel=1
pkgdesc="Python library and CLI tool to automate several tasks in KiCAD"
url="https://github.com/yaqwsx/KiKit"
-# mips, mips64, s390x: py3-shapely
-# aarch64, armv7, armhf, mips, mips64: py3-solidpython
-arch="noarch !mips !mips64 !s390x !aarch64 !armv7 !armhf"
+# riscv64: py3-shapely
+# aarch64, armv7, armhf, mips64: py3-solidpython
+# s390x: kicad
+arch="noarch !riscv64 !aarch64 !armv7 !armhf !s390x"
license="MIT"
depends="
- python3
+ kicad
py3-click
+ py3-commentjson
py3-markdown2
+ py3-pcbnewtransition
py3-pybars3
py3-shapely
py3-solidpython
+ python3
+ "
+makedepends="
+ py3-gpep517
py3-python-versioneer
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/yaqwsx/KiKit/archive/v$pkgver.tar.gz
+
+ 0000-kicad-v7.patch
"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/yaqwsx/KiKit/archive/v$pkgver.tar.gz"
builddir="$srcdir/KiKit-$pkgver"
-options="!check" # Not all dependencies packaged for check
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ cd test/units
+ ../../.testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="38c243f2c8e65a8d961f292558c0eaab9724c8cd0a8af5f5cf569d91b3e9d41d1f94406f0855cc21325676b95a7a967db9d5deac2492ca9d119a166d4fa08f9d py3-kikit-0.7.tar.gz"
+
+sha512sums="
+695ac7c60e6974df8173a328cad4c5b297f06ae572807cb92ae0bdb93ff59e4f26770c6ee09778709a2b6ffd0f6a0a932fdc5876931e4f5011b8125ca6f629c5 py3-kikit-1.2.0.tar.gz
+1ccd934d7f981fbf665336888eb70bc9a11f8133e5fef610fcb48d64290b940e571a9cd9a46a2b4dd7b5d2e0a220d831f4551c2a697bcc941b26485fb945de71 0000-kicad-v7.patch
+"