aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-kthread/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-kthread/APKBUILD')
-rw-r--r--testing/py3-kthread/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-kthread/APKBUILD b/testing/py3-kthread/APKBUILD
new file mode 100644
index 00000000000..c2cbce1bf7a
--- /dev/null
+++ b/testing/py3-kthread/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-kthread
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Killable threads in Python!"
+url="https://github.com/munshigroup/kthread"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="
+ py3-nose
+ py3-pytest
+ "
+source="https://pypi.python.org/packages/source/k/kthread/kthread-$pkgver.tar.gz"
+options="!check" # No tests in PyPi package and no Github releases
+builddir="$srcdir/kthread-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9d59b775c90ff134528dc5209ac9af3a1a2c820a80b20b852e31c8c6a1b3852fb6a5a404c807ce5120e286e3fd0db366699c58748c012db46d63c9a3e62aa3b1 kthread-0.2.2.tar.gz"