aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-liblarch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-liblarch/APKBUILD')
-rw-r--r--testing/py3-liblarch/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-liblarch/APKBUILD b/testing/py3-liblarch/APKBUILD
index d5f797d99d2..8827ce2b664 100644
--- a/testing/py3-liblarch/APKBUILD
+++ b/testing/py3-liblarch/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-liblarch
-pkgver=3.1.0
-pkgrel=0
+pkgver=3.2.0
+pkgrel=4
pkgdesc="A Python library to easily handle complex data structures, with a GTK binding"
url="https://wiki.gnome.org/Projects/liblarch"
arch="noarch"
@@ -10,6 +10,7 @@ license="LGPL-3.0-or-later"
depends="python3 py3-gobject3 gtk+3.0"
makedepends="py3-setuptools"
checkdepends="py3-nose py3-pyflakes xvfb-run"
+subpackages="$pkgname-pyc"
source="https://github.com/getting-things-gnome/liblarch/archive/v$pkgver/liblarch-$pkgver.tar.gz"
builddir="$srcdir/liblarch-$pkgver"
@@ -22,7 +23,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="042a763dd12612d6630c064b5af84011f1fb908626f17f866e103743cdaabb4983f922290287b0138938488a7c9bff33680ef8157f8bbcbc166e4f4f2d008951 liblarch-3.1.0.tar.gz"
+sha512sums="
+d356535f2e60885249be009f7e671fcb1ee02b7d32b7abecc3805c5f6b6e231fc34be0d7a73cd9f9a68dfaae0b1cf0a5bdc54ed3075901a149d58ad6577d92ab liblarch-3.2.0.tar.gz
+"