aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-liblarch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-liblarch/APKBUILD')
-rw-r--r--testing/py3-liblarch/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-liblarch/APKBUILD b/testing/py3-liblarch/APKBUILD
new file mode 100644
index 00000000000..8827ce2b664
--- /dev/null
+++ b/testing/py3-liblarch/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-liblarch
+pkgver=3.2.0
+pkgrel=4
+pkgdesc="A Python library to easily handle complex data structures, with a GTK binding"
+url="https://wiki.gnome.org/Projects/liblarch"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3 py3-gobject3 gtk+3.0"
+makedepends="py3-setuptools"
+checkdepends="py3-nose py3-pyflakes xvfb-run"
+subpackages="$pkgname-pyc"
+source="https://github.com/getting-things-gnome/liblarch/archive/v$pkgver/liblarch-$pkgver.tar.gz"
+builddir="$srcdir/liblarch-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ xvfb-run python3 run-tests
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+d356535f2e60885249be009f7e671fcb1ee02b7d32b7abecc3805c5f6b6e231fc34be0d7a73cd9f9a68dfaae0b1cf0a5bdc54ed3075901a149d58ad6577d92ab liblarch-3.2.0.tar.gz
+"