aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-libnacl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-libnacl/APKBUILD')
-rw-r--r--testing/py3-libnacl/APKBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/testing/py3-libnacl/APKBUILD b/testing/py3-libnacl/APKBUILD
index a54e3af147c..4ec4e47ba66 100644
--- a/testing/py3-libnacl/APKBUILD
+++ b/testing/py3-libnacl/APKBUILD
@@ -1,30 +1,43 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-libnacl
-_pkgname=libnacl
-pkgver=1.7.2
-pkgrel=1
+pkgver=2.1.0
+pkgrel=0
pkgdesc="Python bindings for libsodium/tweetnacl"
url="https://libnacl.readthedocs.org/"
-arch="noarch !armhf !armv7 !x86" # Tests fail on the builder but pass on CI
+arch="noarch"
license="Apache-2.0"
-makedepends="py3-setuptools libsodium-dev"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/saltstack/libnacl/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+depends="libsodium"
+makedepends="
+ libsodium-dev
+ py3-gpep517
+ py3-poetry-core
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/saltstack/libnacl/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir"/libnacl-$pkgver
replaces="py-libnacl" # Backwards compatibility
provides="py-libnacl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest discover --start-directory tests -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="a4efbf73f73d9493ac365efa5a5bd6481f85ce4c880ad236bbf7478090bdea857e78e33e445c4e467d2a2032040863b835f32f9a942d2f1e467015bd76b0d469 libnacl-1.7.2.tar.gz"
+sha512sums="
+717aec5fcc9ffbb7fef5f265861f86a087cc1ad1a122d752b1d8447bf495b98106056f19ff2ad1001ca81b84085ae6167ec96db2c2f3823f0f9a72a2a54788df py3-libnacl-2.1.0.tar.gz
+"