aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-librtmp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-librtmp/APKBUILD')
-rw-r--r--testing/py3-librtmp/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-librtmp/APKBUILD b/testing/py3-librtmp/APKBUILD
index 63fadbfde55..d41fa5cb8ee 100644
--- a/testing/py3-librtmp/APKBUILD
+++ b/testing/py3-librtmp/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-librtmp
_pkgname=python-librtmp
pkgver=0.3.0
-pkgrel=2
+pkgrel=6
pkgdesc="Python bindings for librtmp, built with cffi"
url="https://github.com/chrippa/python-librtmp"
arch="all"
@@ -11,6 +11,7 @@ license="BSD-2-Clause"
depends="py3-cffi"
makedepends="python3-dev py3-setuptools rtmpdump-dev"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -26,7 +27,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="1fa529f5c68341f225849061cbcf6883f80e48a492fae8319336ea1e17c22070d5bd204f768b2561b0ef8dfdf29b38789673fab3d3386290143eb94d2b51b8fe python-librtmp-0.3.0.tar.gz"