aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-lzo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-lzo/APKBUILD')
-rw-r--r--testing/py3-lzo/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py3-lzo/APKBUILD b/testing/py3-lzo/APKBUILD
new file mode 100644
index 00000000000..b53e9bdc7e1
--- /dev/null
+++ b/testing/py3-lzo/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=py3-lzo
+pkgver=1.16
+pkgrel=0
+pkgdesc="Python bindings for the LZO data compression library"
+url="https://github.com/jd-boyd/python-lzo"
+arch="all"
+license="GPL-2.0-or-later"
+depends="python3"
+makedepends="
+ lzo-dev
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://github.com/jd-boyd/python-lzo/archive/v$pkgver/py3-lzo-$pkgver.tar.gz"
+builddir="$srcdir/python-lzo-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/python_lzo-$pkgver-*.whl
+}
+
+sha512sums="
+19a96a3b545d7f7addc549e1b928f39df57ec63acc35bedb2d625bd513fcaf4e1efebcaefc3e9ce45b56ee8ecd481027ceee38b4515532e6800ccf45e74e8faf py3-lzo-1.16.tar.gz
+"