aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-manuel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-manuel/APKBUILD')
-rw-r--r--testing/py3-manuel/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-manuel/APKBUILD b/testing/py3-manuel/APKBUILD
index 8f650dc331b..60075d12b1f 100644
--- a/testing/py3-manuel/APKBUILD
+++ b/testing/py3-manuel/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=py3-manuel
-pkgver=1.10.1
-pkgrel=0
+pkgver=1.12.4
+pkgrel=2
pkgdesc="mix and match traditional doctests with custom test syntax"
url="https://github.com/benji-york/manuel"
arch="noarch"
license="Apache-2.0"
-depends="python3"
+depends="python3 py3-six"
makedepends="py3-setuptools"
checkdepends="py3-zope-testing"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/benji-york/manuel/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/manuel-$pkgver"
+options="!check" # fail matching exact string against newer dep versions
build() {
python3 setup.py build
@@ -22,7 +24,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="7109852a80097a12237a363c91ac433dd2662e238ab4f20757b4d4b93019d0ada19069fd45a13a66128adf4dbc32f162d12a90879db2f2eb4748635118d75072 py3-manuel-1.10.1.tar.gz"
+sha512sums="
+e39c93a6be92b2a5c09c461e2341690f670919b9bcb7665771cba0a0a4f6d695e4ad1ae53641f73f8e54b5ad8b4485831b480874936dc2ad17cbc88abfe2935c py3-manuel-1.12.4.tar.gz
+"