aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-marshmallow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-marshmallow/APKBUILD')
-rw-r--r--testing/py3-marshmallow/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/testing/py3-marshmallow/APKBUILD b/testing/py3-marshmallow/APKBUILD
index e5ddd66b262..15a326f110c 100644
--- a/testing/py3-marshmallow/APKBUILD
+++ b/testing/py3-marshmallow/APKBUILD
@@ -1,31 +1,36 @@
# Contributor: Alex McGrath <amk@amk.ie>
-# Maintainer: Alex McGrath <amk@amk.ie>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-marshmallow
_pkgname=marshmallow
-pkgver=3.14.1
-pkgrel=1
+pkgver=3.21.1
+pkgrel=0
pkgdesc="A lightweight library for converting complex objects to and from simple Python datatypes"
url="https://github.com/marshmallow-code/marshmallow"
-arch="all"
+arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-flit-core py3-gpep517 py3-wheel"
checkdepends="py3-pytest py3-tz py3-simplejson"
+subpackages="$pkgname-pyc"
source="py3-marshmallow-$pkgver.tar.gz::https://github.com/marshmallow-code/marshmallow/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_unknown_parameter_value_is_validated'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-6e3586f3a6d30817642e05f9510e394fb1d36a8fefd10f83b2e58802c0a2295b0f492b5ad97fe0188235ffbcb1a6abdbfcce2142e07be4d92ee743d39e6cc878 py3-marshmallow-3.14.1.tar.gz
+6de06ced6a58ef0c312ee4c1edfbe011401bba08c27fcf2dd2c3e44cb072cded1cf5f16a4d4945344d56f0d26b5eb165f6d031b50c215f122c7cc6fe25389318 py3-marshmallow-3.21.1.tar.gz
"