aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-marshmallow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-marshmallow/APKBUILD')
-rw-r--r--testing/py3-marshmallow/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/testing/py3-marshmallow/APKBUILD b/testing/py3-marshmallow/APKBUILD
index 1b080558b48..5dc185bec5d 100644
--- a/testing/py3-marshmallow/APKBUILD
+++ b/testing/py3-marshmallow/APKBUILD
@@ -1,29 +1,36 @@
# Contributor: Alex McGrath <amk@amk.ie>
-# Maintainer: Alex McGrath <amk@amk.ie>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-marshmallow
_pkgname=marshmallow
-pkgver=3.10.0
+pkgver=3.21.1
pkgrel=1
pkgdesc="A lightweight library for converting complex objects to and from simple Python datatypes"
url="https://github.com/marshmallow-code/marshmallow"
-arch="all"
+arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-flit-core py3-gpep517 py3-wheel"
checkdepends="py3-pytest py3-tz py3-simplejson"
+subpackages="$pkgname-pyc"
source="py3-marshmallow-$pkgver.tar.gz::https://github.com/marshmallow-code/marshmallow/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_unknown_parameter_value_is_validated'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="b3b854cc6e820385a05bcabd6dd66a87ea41dfd225eafdd7a6a8b9e82bd057ce8e19fb5ee56e5c207a4b21cdfd7dce704d567695f09a3316f80b791a1e7f362b py3-marshmallow-3.10.0.tar.gz"
+sha512sums="
+6de06ced6a58ef0c312ee4c1edfbe011401bba08c27fcf2dd2c3e44cb072cded1cf5f16a4d4945344d56f0d26b5eb165f6d031b50c215f122c7cc6fe25389318 py3-marshmallow-3.21.1.tar.gz
+"