aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-minidb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-minidb/APKBUILD')
-rw-r--r--testing/py3-minidb/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-minidb/APKBUILD b/testing/py3-minidb/APKBUILD
new file mode 100644
index 00000000000..c773a7f2263
--- /dev/null
+++ b/testing/py3-minidb/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Thiago Perrotta <tbperrotta@gmail.com>
+# Maintainer: Thiago Perrotta <tbperrotta@gmail.com>
+pkgname=py3-minidb
+pkgver=2.0.7
+pkgrel=3
+pkgdesc="Simple SQLite3 store for Python objects"
+url="https://thp.io/2010/minidb"
+arch="noarch"
+license="ISC"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/m/minidb/minidb-$pkgver.tar.gz"
+builddir="$srcdir/minidb-$pkgver/"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=. pytest
+}
+
+package() {
+ python3 setup.py install --root="$pkgdir" --skip-build
+}
+
+sha512sums="
+dc04d2d51fdc4ecf30e234cb25e17bf0cd5c320dfca6bdd306b61eced89fe8f1fb5df93111ec0c04f1b258ecde467203a968e61b913feee87301dec7e93d9412 minidb-2.0.7.tar.gz
+"