aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-mypy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-mypy/APKBUILD')
-rw-r--r--testing/py3-mypy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-mypy/APKBUILD b/testing/py3-mypy/APKBUILD
new file mode 100644
index 00000000000..85dc6948766
--- /dev/null
+++ b/testing/py3-mypy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=py3-mypy
+pkgver=0.770
+pkgrel=0
+pkgdesc="Optional static typing for Python (PEP484)"
+url="https://www.mypy-lang.org/"
+arch="noarch"
+license="MIT"
+depends="py3-mypy-extensions py3-typing-extensions py3-typed-ast"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-tox"
+source="https://files.pythonhosted.org/packages/source/m/mypy/mypy-$pkgver.tar.gz"
+builddir="$srcdir/"mypy-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ tox
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0137a2a68f89a05b27afd3e579f54bf7607494ffe6870aec7711c16f4d8737fffea5b2eb617ca6077906dcfdea557cc1407442f5da811974098b3fb934e59bd7 mypy-0.770.tar.gz"