aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ncclient/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ncclient/APKBUILD')
-rw-r--r--testing/py3-ncclient/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/py3-ncclient/APKBUILD b/testing/py3-ncclient/APKBUILD
index 76af6c57c83..572bb997bbf 100644
--- a/testing/py3-ncclient/APKBUILD
+++ b/testing/py3-ncclient/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
pkgname=py3-ncclient
-pkgver=0.6.12
-pkgrel=0
+pkgver=0.6.13
+pkgrel=2
pkgdesc="Library for NETCONF clients"
url="https://github.com/ncclient/ncclient"
arch="noarch"
license="Apache-2.0"
depends="py3-lxml py3-paramiko py3-six py3-setuptools"
checkdepends="py3-mock py3-nose"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ncclient/ncclient/archive/v$pkgver.tar.gz"
builddir="$srcdir"/ncclient-$pkgver
@@ -24,9 +25,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-32b324f255516676962a91550c7ffac7d95a2dac2b850071fc1bdf2f49dc2958c8ed3b1313d0bb8ef69e94171b3e5063ab36abf05e5a37bf137b7a0659a34f35 py3-ncclient-0.6.12.tar.gz
+650d07477d48cd209ef758ebd1716e48c4021c3d681f0ce2e9065ca5f34ace82079f5577884d26fc99e552c6f4cd7b59a9bf8866008e7b2985f1d8b23cc8d61f py3-ncclient-0.6.13.tar.gz
"