aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-netdisco/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-netdisco/APKBUILD')
-rw-r--r--testing/py3-netdisco/APKBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/testing/py3-netdisco/APKBUILD b/testing/py3-netdisco/APKBUILD
deleted file mode 100644
index d0f48de83a7..00000000000
--- a/testing/py3-netdisco/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-netdisco
-_pkgname=netdisco
-pkgver=2.8.2
-pkgrel=1
-pkgdesc="Python library to scan local network for services and devices"
-url="https://github.com/home-assistant/netdisco/"
-arch="noarch"
-license="Apache-2.0"
-depends="py3-zeroconf py3-requests python3"
-checkdepends="py3-pytest"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="668d3549ff26a5dff20546bdb7bb084f5660b7190d7e0c177319c43f79e5bfa57a259ba5a11c6970ba251c76f4be46d6307996c341d7d0bcdebb9ccad53173db netdisco-2.8.2.tar.gz"