aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-nikola/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-nikola/APKBUILD')
-rw-r--r--testing/py3-nikola/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/testing/py3-nikola/APKBUILD b/testing/py3-nikola/APKBUILD
index d5c429df84a..3d35c003db3 100644
--- a/testing/py3-nikola/APKBUILD
+++ b/testing/py3-nikola/APKBUILD
@@ -2,38 +2,44 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-nikola
_pyname=Nikola
-pkgver=8.1.3
+pkgver=8.3.0
pkgrel=2
pkgdesc="Modular, fast, simple, static python website generator"
options="!check" # Tests require more packages
url="https://getnikola.com"
# armv7, armhf, s390x, x86: py3-piexif
-# aarch64: py3-inotify
-# mips64 blocked by py3-doit
-arch="noarch !armv7 !armhf !s390x !x86 !aarch64 !mips64"
+arch="noarch !armv7 !armhf !s390x !x86"
license="MIT"
depends="py3-babel py3-blinker py3-doit py3-dateutil py3-docutils py3-logbook
py3-lxml py3-mako py3-markdown py3-natsort py3-piexif py3-pillow
py3-pygments py3-pyphen py3-pyrss2gen py3-requests py3-unidecode py3-yapsy
"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
source="https://files.pythonhosted.org/packages/source/N/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
-replaces="py-nikola" # Backwards compatibility
+replaces="py-nikola" # Backwards compatibility
provides="py-nikola=$pkgver-r$pkgrel" # Backwards compatibility
+subpackages="$pkgname-doc $pkgname-pyc"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3 -c /dev/null
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests
}
-sha512sums="7b6a8391d023a339125392082cc3d2ea2a2fe25b8938bd82b8c9efe0cbb3e8b83537f1bd00d97a648e3fc2b096e673702026fa3942ab9c97e76bf21b5afefe16 Nikola-8.1.3.tar.gz"
+sha512sums="
+9b25eb90fa560b45e8cd0b03f24523859548353f2a4d2ac91b23b05bfb614d20456bb71f1aaa5702b6d6ab7980696aeb2f5ccc3c00ebc648cfcad49619481247 Nikola-8.3.0.tar.gz
+"