aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-nmap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-nmap/APKBUILD')
-rw-r--r--testing/py3-nmap/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-nmap/APKBUILD b/testing/py3-nmap/APKBUILD
index c746a8f1de6..cf93c6eab48 100644
--- a/testing/py3-nmap/APKBUILD
+++ b/testing/py3-nmap/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-nmap
_pkgname=nmap
-pkgver=0.6.4
-pkgrel=0
+pkgver=0.7.1
+pkgrel=2
pkgdesc="Python3 class to use nmap and access scan results"
-options="!check" # Some tests fail due to missing file
+options="!check" # tests prompt for doas password (wtf)
url="http://xael.org/pages/python-nmap-en.html"
arch="noarch"
license="GPL-3.0-or-later"
depends="nmap"
makedepends="py3-setuptools"
checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
source="http://xael.org/pages/python-$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/python-$_pkgname-$pkgver
@@ -27,7 +28,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="9c5176087e39271015283abcd8fc4d7828c063e9209ec1e549737142864e199a78014c2ab518f9afcb75f2ea2affc94fa1f612c9d2849d25eed9589a03864b76 python-nmap-0.6.4.tar.gz"
+sha512sums="
+3a1d3b7120527d56148ddf3589bf8c4b749bb549e93c65a973d3edacb492656d0060d82606f88c5d1342dabdce00b8957bf09e01a5ce42f3a670ff3778d9e0ea python-nmap-0.7.1.tar.gz
+"