aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-notify2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-notify2/APKBUILD')
-rw-r--r--testing/py3-notify2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-notify2/APKBUILD b/testing/py3-notify2/APKBUILD
new file mode 100644
index 00000000000..c64edad4e70
--- /dev/null
+++ b/testing/py3-notify2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname=py3-notify2
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Python interface to DBus notifications"
+url="https://pypi.org/project/notify2/"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-dbus py3-gobject3"
+checkdepends="xvfb-run dunst dbus"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/n/notify2/notify2-$pkgver.tar.gz
+ test-wrapper.sh"
+builddir="$srcdir/notify2-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ dbus-run-session xvfb-run \
+ sh "$srcdir"/test-wrapper.sh
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0b69a64e0a7e4955ee767c975db92c5c60d28c0e54f77498cfb98390771a8f536631fc34e42b5c46c138dfa1054b5516a0809b8e3b0cb9237a39825ddb827109 notify2-0.3.1.tar.gz
+fd28280cbe7ec98c53cd898b7ebe843f1df2a953ce7e7e0d6abf50f66ca52481095338858439dec61a660a84cffe8fda4122afbc7a73da24e66408891c63c79a test-wrapper.sh"