aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-notifymail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-notifymail/APKBUILD')
-rw-r--r--testing/py3-notifymail/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-notifymail/APKBUILD b/testing/py3-notifymail/APKBUILD
index 443ec85a37a..35a69cc43b7 100644
--- a/testing/py3-notifymail/APKBUILD
+++ b/testing/py3-notifymail/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-notifymail
_pkgname=notifymail
pkgver=1.1
-pkgrel=3
+pkgrel=6
pkgdesc="A Python module to send emails"
url="https://github.com/davidfstr/notifymail/"
arch="noarch"
@@ -12,6 +12,7 @@ replaces="py-notifymail" # for backwards compatibility
provides="py-notifymail=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,7 +23,7 @@ build() {
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="f06bf000c0855c852bc4fccfb5da5c625bbabe334640dc6557e6518a5657b61ec2fd546cb92ef63cb66b64c6ce469cfb94da21f844e1c6934cc1339a08fe3f1a notifymail-1.1.tar.gz"