aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-nwdiag/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-nwdiag/APKBUILD')
-rw-r--r--testing/py3-nwdiag/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-nwdiag/APKBUILD b/testing/py3-nwdiag/APKBUILD
index 6043357d58e..d70f968885c 100644
--- a/testing/py3-nwdiag/APKBUILD
+++ b/testing/py3-nwdiag/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-nwdiag
_pkgname=nwdiag
-pkgver=2.0.0
-pkgrel=1
+pkgver=3.0.0
+pkgrel=2
pkgdesc="Generate network-diagram image file from spec-text file"
-url="https://pypi.python.org/pypi/nwdiag"
+url="https://pypi.org/project/nwdiag"
arch="noarch"
license="Apache-2.0"
depends="py3-funcparserlib py3-blockdiag py3-pillow"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -21,7 +22,10 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/rackdiag/tests
}
-sha512sums="b9064c56955c68074e6c9e262f90fadde5b0c9412d86e6fe3c7f76745638fb02a62ab720b515d3b81d1b896cac18df55622893d73380dfe003a4004b0b8b50e5 nwdiag-2.0.0.tar.gz"
+sha512sums="
+3443d2599c91c2e1a267172fe1c35ead18f733d4eebb7313597fdae3b8cac9cd8e0c2700750aef5b2a332851cc3e6a1942d3ffe165f55cdd68dc54430f0dd86f nwdiag-3.0.0.tar.gz
+"