aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pecan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pecan/APKBUILD')
-rw-r--r--testing/py3-pecan/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/py3-pecan/APKBUILD b/testing/py3-pecan/APKBUILD
deleted file mode 100644
index d32811296a9..00000000000
--- a/testing/py3-pecan/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Duncan Bellamy <dunk@denkimushi.com>
-# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
-pkgname=py3-pecan
-pkgver=1.4.1
-pkgrel=0
-pkgdesc="A WSGI object-dispatching web framework, designed to be lean and fast, with few dependencies"
-url="https://github.com/pecan/pecan"
-arch="noarch"
-license="BSD-3-Clause"
-depends="python3 py3-logutils py3-mako py3-six py3-webob py3-webtest"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pecan/pecan-$pkgver.tar.gz"
-builddir="$srcdir/pecan-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-# deselect test which looks like it should pass
-check() {
- rm pecan/tests/__init__.py
- python3 -m pytest --deselect=pecan/tests/test_base.py::TestAppRoot::test_controller_lookup_by_string_path
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-bd5ba47935e2d97677bcdc25ad4678ec63293e0000750fa3b39a2447be326dc7e1fd4cf77ac0519e1b7c6ecc7ba7c3e66d98443e78e647fba92383f048775c83 py3-pecan-1.4.1.tar.gz
-"