aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pivy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pivy/APKBUILD')
-rw-r--r--testing/py3-pivy/APKBUILD26
1 files changed, 10 insertions, 16 deletions
diff --git a/testing/py3-pivy/APKBUILD b/testing/py3-pivy/APKBUILD
index 1aa40afbeaf..86d311220a2 100644
--- a/testing/py3-pivy/APKBUILD
+++ b/testing/py3-pivy/APKBUILD
@@ -1,34 +1,29 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-pivy
-_pkgname=pivy
-pkgver=0.6.7
+pkgver=0.6.9_alpha0
pkgrel=0
pkgdesc="Python3 bindings for coin"
url="https://github.com/coin3d/pivy"
-# riscv64 blocked by qt5-qtwebengine via py3-pyside2
-# py3-pyside2 is not available on armhf
-arch="all !armhf !riscv64"
+# riscv64 blocked by py3-pyside6
+arch="all !riscv64"
license="ISC"
-depends="py3-pyside2"
-makedepends="swig soqt-dev qt5-qtbase-dev python3-dev glu-dev cmake"
+depends="py3-pyside6"
+makedepends="swig soqt-dev qt6-qtbase-dev python3-dev glu-dev cmake samurai"
checkdepends="py3-pytest"
options="!check" # test suite is interactive and requires full installation
-source="$pkgname-$pkgver.tar.gz::https://github.com/coin3d/pivy/archive/refs/tags/$pkgver.tar.gz
- qt5.patch
- "
-builddir="$srcdir/$_pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/coin3d/pivy/archive/refs/tags/${pkgver//_alpha/.a}.tar.gz"
+builddir="$srcdir/pivy-${pkgver//_alpha/.a}"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- $CMAKE_CROSSOPTS .
+ $CMAKE_CROSSOPTS
cmake --build build
}
@@ -37,6 +32,5 @@ package() {
}
sha512sums="
-606eac3527b5906ad6884c25775b5625bfd2a1b1c78f75017b05e662d622c75d30e70fd5785ec2145902f5a02d99098b52cc776aee12fab02f0319762ee104b0 py3-pivy-0.6.7.tar.gz
-7750ded3eb09da510ba5f84e7957c2ae1f92be0df280901fd9c9eba4164758a8f2d436e2d6ae7634a91aed12609f4eefd181922e6caed0b4906c6bc9dbd7b562 qt5.patch
+1bfefd58d2921c8be170a97efa30cad53b01f636ea0cf236acca242be4f691669a4c310cd61c64d3e0c55e55e8be96d36945cd244380ddc0b3a06170d0f8b691 py3-pivy-0.6.9_alpha0.tar.gz
"