aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pockethernet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pockethernet/APKBUILD')
-rw-r--r--testing/py3-pockethernet/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-pockethernet/APKBUILD b/testing/py3-pockethernet/APKBUILD
index b05941217ec..5de265bfd07 100644
--- a/testing/py3-pockethernet/APKBUILD
+++ b/testing/py3-pockethernet/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Martijn Braam <martijn@brixit.nl>
+# Contributor: Martijn Braam <martijn@brixit.nl>
pkgname=py3-pockethernet
_pyname=pockethernet
-pkgver=0.2.1
+pkgver=0.7.0
pkgrel=2
pkgdesc="Library for controlling the Pockethernet"
url="https://gitlab.com/MartijnBraam/pockethernet-protocol"
@@ -10,8 +11,9 @@ license="MIT"
depends="python3 py3-cobs py3-crc16"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir=$srcdir/$_pyname-$pkgver
+subpackages="$pkgname-pyc"
+source="https://gitlab.com/MartijnBraam/pockethernet-protocol/-/archive/$pkgver/pockethernet-protocol-$pkgver.tar.gz"
+builddir=$srcdir/pockethernet-protocol-$pkgver
build() {
python3 setup.py build
@@ -22,6 +24,8 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="df8c438868a15e8e401a62b3033a6e81610fdb4d54a66be42a8691b965820f2e58ddf8a31a8334412f8decc0c771849f8c02798d64e71413a3b821365ed5e3cb pockethernet-0.2.1.tar.gz"
+sha512sums="
+e312f712b8ca914d307a9d2a4a82d5c954f210c1fb7936442e0c5608a8bab92a5b2e100a8e5be24a249f9ca15e6de2086c50bebd48ba6dcf69f70bf50e7b2c4d pockethernet-protocol-0.7.0.tar.gz
+"