aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-prawcore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-prawcore/APKBUILD')
-rw-r--r--testing/py3-prawcore/APKBUILD28
1 files changed, 0 insertions, 28 deletions
diff --git a/testing/py3-prawcore/APKBUILD b/testing/py3-prawcore/APKBUILD
deleted file mode 100644
index 9769a9189da..00000000000
--- a/testing/py3-prawcore/APKBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
-# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
-pkgname=py3-prawcore
-pkgver=1.0.1
-pkgrel=4
-pkgdesc="a low-level communication layer for PRAW 4+"
-options="net" # To fetch unpackaged test dependencies
-url="https://github.com/praw-dev/prawcore"
-arch="noarch"
-license="BSD-2-Clause"
-depends="py3-setuptools py3-requests"
-checkdepends="py3-mock"
-source="$pkgname-$pkgver.tar.gz::https://github.com/praw-dev/prawcore/archive/v$pkgver.tar.gz"
-builddir="$srcdir/prawcore-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="6efe8faa685aa92a04309c4c24963a2a540335ad0bed31b990d840732ddf726789688171f4ead4daf831e89da5c95c17861a079dfc9ae3de254d2690bcff1c8b py3-prawcore-1.0.1.tar.gz"