aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-preshed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-preshed/APKBUILD')
-rw-r--r--testing/py3-preshed/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/py3-preshed/APKBUILD b/testing/py3-preshed/APKBUILD
deleted file mode 100644
index 4fc050cf428..00000000000
--- a/testing/py3-preshed/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Oleg Titov <oleg.titov@gmail.com>
-pkgname=py3-preshed
-pkgver=3.0.5
-pkgrel=2
-pkgdesc="Cython hash tables that assume keys are pre-hashed"
-url="https://github.com/explosion/preshed"
-arch="all"
-license="MIT"
-depends="python3 py3-cymem py3-murmurhash"
-makedepends="python3-dev py3-setuptools cython"
-checkdepends="py3-pytest"
-subpackages="$pkgname-doc"
-source="preshed-$pkgver.tar.gz::https://github.com/explosion/preshed/archive/v$pkgver.tar.gz"
-builddir="$srcdir/preshed-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py install --root="$PWD/tmp_install"
-
- cd tmp_install/$(python3 -c "import site; print(site.getsitepackages()[0])")
-
-
- PYTHONPATH="$PWD/usr/lib" \
- pytest-3 preshed
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
-}
-
-sha512sums="8ff93890e421ad67504152c06265c39cff373e0f6c0d4fae78b6ab5d4847611dc424cc00fb809fafa8d6880d710ed927f7db36d0bd80f98a51f4ba456b164b91 preshed-3.0.5.tar.gz"