aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pronouncing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pronouncing/APKBUILD')
-rw-r--r--testing/py3-pronouncing/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-pronouncing/APKBUILD b/testing/py3-pronouncing/APKBUILD
new file mode 100644
index 00000000000..6e26d227021
--- /dev/null
+++ b/testing/py3-pronouncing/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-pronouncing
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="A simple interface for the CMU pronouncing dictionary"
+url="https://github.com/aparrish/pronouncingpy"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-cmudict
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://pypi.python.org/packages/source/p/pronouncing/pronouncing-$pkgver.tar.gz"
+builddir="$srcdir/pronouncing-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a10ceef3e9a6ff0788f5ea6446c81d5c00649d05d085d42074d74aa547edf1b41357792ee532e9e5605ac345f351982c25a26a423e41eda78df921e13d28ebe9 pronouncing-0.2.0.tar.gz"