aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-py-radix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-py-radix/APKBUILD')
-rw-r--r--testing/py3-py-radix/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/testing/py3-py-radix/APKBUILD b/testing/py3-py-radix/APKBUILD
index 4a0df4f2bc3..f6ec91b5bc9 100644
--- a/testing/py3-py-radix/APKBUILD
+++ b/testing/py3-py-radix/APKBUILD
@@ -1,9 +1,8 @@
-# Contributor:
# Maintainer: Kristóf Jakab <jakab.kristof@balasys.hu>
pkgname=py3-py-radix
_pkgname=py-radix
pkgver=0.10.0
-pkgrel=4
+pkgrel=9
pkgdesc="An implementation of a radix tree for Python"
url="https://github.com/mjschultz/py-radix"
arch="all"
@@ -11,7 +10,11 @@ license="BSD-4-Clause AND ISC"
depends="python3"
makedepends="py3-setuptools python3-dev"
checkdepends="py3-coverage py3-nose"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/mjschultz/py-radix/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/mjschultz/py-radix/archive/v$pkgver.tar.gz
+ python3.10-support.patch
+ assertEquals.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-radix # Backwards compatibility
@@ -26,7 +29,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="b4b6a35aad76c19c2eaa5bff828cbec5182cc4074397d4b9e5c39ac76bd9045c86600ed52ac06632abac8a9e70d6e82aa9e741ab3eb92970453bb14acdba72ea py-radix-0.10.0.tar.gz"
+sha512sums="
+b4b6a35aad76c19c2eaa5bff828cbec5182cc4074397d4b9e5c39ac76bd9045c86600ed52ac06632abac8a9e70d6e82aa9e741ab3eb92970453bb14acdba72ea py-radix-0.10.0.tar.gz
+56808e892ebcc951f76bfb21647687ccf8c2d3e605c64c650ca95e54a766e8f110bfa087fdc1921e9ba68109dbbf8220885a9c12dcb6ef69bf7695d7722a75b0 python3.10-support.patch
+cb7abba0dd5f0ea24c953d5c7a5c2d8dcdaf86b5ce30aa49d633de2572967afef2475019c88eaeddc2397633b08eef5c5607ac34bedf7afc4d1410108c61f0f7 assertEquals.patch
+"