aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycosat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pycosat/APKBUILD')
-rw-r--r--testing/py3-pycosat/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/testing/py3-pycosat/APKBUILD b/testing/py3-pycosat/APKBUILD
index 0d9192d61cb..7716bcd9038 100644
--- a/testing/py3-pycosat/APKBUILD
+++ b/testing/py3-pycosat/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-pycosat
_pkgname=pycosat
-pkgver=0.6.3
-pkgrel=2
+pkgver=0.6.6
+pkgrel=1
pkgdesc="Python bindings to picosat (a SAT solver)"
-url="https://github.com/ContinuumIO/pycosat"
+url="https://github.com/conda/pycosat"
arch="all"
license="MIT"
-makedepends="python3-dev"
-source="https://github.com/ContinuumIO/pycosat/archive/$pkgver/$_pkgname-$pkgver.tar.gz
+makedepends="python3-dev py3-setuptools"
+source="https://github.com/conda/pycosat/archive/$pkgver/$_pkgname-$pkgver.tar.gz
musl-compat.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -19,13 +19,15 @@ build() {
}
check() {
- PYTHONPATH="$(dirname ./build/lib.linux-*-3.*/*.so)" \
+ PYTHONPATH="$(echo build/lib.linux*)" \
python3 test_pycosat.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="6163f9879d4ed98486f36990f0134db0a9b6096a8507312a1013d707b0dcb7e963845a5959c601f672a53a5db8c80b63d3184a0ef906b2ec563ca1a4c63850fa pycosat-0.6.3.tar.gz
-57fae28c1d9f9e5fd2c8800ec664e0c43b04935f540ab2576fd660cb902e62edcc727aab3f7dacd33db1e775d49ebdffc24fbe4a4136ec5e3ea54cc5c37b2cef musl-compat.patch"
+sha512sums="
+a831bee95746c19133463b903429aaf7619407733d49128fdb0afe368e62bcdffc1406b4bbfdbbf67b1a96953bfba2f23a7e2dc151979d61efb29facb8609dc4 pycosat-0.6.6.tar.gz
+57fae28c1d9f9e5fd2c8800ec664e0c43b04935f540ab2576fd660cb902e62edcc727aab3f7dacd33db1e775d49ebdffc24fbe4a4136ec5e3ea54cc5c37b2cef musl-compat.patch
+"