aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pygfm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pygfm/APKBUILD')
-rw-r--r--testing/py3-pygfm/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/py3-pygfm/APKBUILD b/testing/py3-pygfm/APKBUILD
index c51e08eb1a3..561c58c29da 100644
--- a/testing/py3-pygfm/APKBUILD
+++ b/testing/py3-pygfm/APKBUILD
@@ -3,8 +3,8 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=py3-pygfm
_pkgname=py-gfm
-pkgver=1.0.0
-pkgrel=1
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Github-Flavored Markdown for Python-Markdown"
options="!check"
url="https://github.com/zopieux/py-gfm"
@@ -13,6 +13,7 @@ license="BSD-3-Clause"
depends="python3 py3-markdown"
makedepends="py3-setuptools"
checkdepends="py3-codecov py3-coverage py3-coveralls"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/Zopieux/py-gfm/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -28,7 +29,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="eb1b190d4b8ebdf229141965cad57531bdb7b2c834acf9ef62a06955f5c61fdc16e85a0871121f99d2bdb0d07482ed9bc84c52e85e6a446f49e869780c463b89 py3-pygfm-1.0.0.tar.gz"
+sha512sums="
+45d62280465bdc0cc51fc3e74486d0923c71fce7497ca29d68ba7bce232bf423d209b7ee54170d2ae283374c4e5979766d95e13ce9285bff303e7a5a83e1e12b py3-pygfm-2.0.0.tar.gz
+"