aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyisbn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyisbn/APKBUILD')
-rw-r--r--testing/py3-pyisbn/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/py3-pyisbn/APKBUILD b/testing/py3-pyisbn/APKBUILD
index 662956f4a13..897e03ddd8b 100644
--- a/testing/py3-pyisbn/APKBUILD
+++ b/testing/py3-pyisbn/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pyisbn
_pkgname=pyisbn
-pkgver=1.2.1
+pkgver=1.3.1
pkgrel=2
pkgdesc="A module for working with 10- and 13-digit ISBNs"
url="https://github.com/JNRowe/pyisbn"
@@ -10,6 +10,7 @@ arch="noarch"
license="GPL-3.0-or-later"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -21,7 +22,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="4ba93722350803cde1bf969421864e27f4aaf562021e7a4400b182aa4c503ce4e33e5e328aabaef48071704d9533fc42cb95d69e4a5e817ea864149affe6ec85 pyisbn-1.2.1.tar.gz"
+sha512sums="
+3abb14ebcd6d1feaf892fcfdd6da19a3010b1d80c898e5a3ff871e759e7833b09a988ff1b7a9f46cbfdd2eb44172c7ddd0a499b9e40eea4fed89df3d467bf0c1 pyisbn-1.3.1.tar.gz
+"