aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pymeta3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pymeta3/APKBUILD')
-rw-r--r--testing/py3-pymeta3/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-pymeta3/APKBUILD b/testing/py3-pymeta3/APKBUILD
index f34e51ab835..f7f5ace3ccb 100644
--- a/testing/py3-pymeta3/APKBUILD
+++ b/testing/py3-pymeta3/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-pymeta3
pkgver=0.5.1
-pkgrel=1
+pkgrel=5
pkgdesc="general object-oriented pattern matcher for Python 3"
url="https://github.com/wbond/pymeta3"
arch="noarch"
@@ -12,6 +12,7 @@ makedepends="
"
_pyname="PyMeta3"
_pypiprefix="${_pyname%${_pyname#?}}"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
options="!check" # No tests provided
@@ -21,6 +22,6 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="3a44661ae550cbb56fb0397af835e3a12ac81243d4a2f1ac3d9d713a3955cb276441e112e7cd75beb7ebd0c4bfa03014ec8b625750dffeec891b5b7802b72575 PyMeta3-0.5.1.tar.gz"