aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pypandoc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pypandoc/APKBUILD')
-rw-r--r--testing/py3-pypandoc/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/py3-pypandoc/APKBUILD b/testing/py3-pypandoc/APKBUILD
index 6221dad8e0c..40287133888 100644
--- a/testing/py3-pypandoc/APKBUILD
+++ b/testing/py3-pypandoc/APKBUILD
@@ -1,20 +1,23 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-pypandoc
-pkgver=1.5
-pkgrel=1
+pkgver=1.13
+pkgrel=0
pkgdesc="Thin wrapper for pandoc"
-url="https://github.com/bebraw/pypandoc"
-arch="x86_64" # pandoc
+url="https://github.com/NicklasTegner/pypandoc"
+arch="aarch64 x86_64" # pandoc
license="MIT"
depends="python3 pandoc"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-poetry-core"
options="!check" # missing pandoc-citeproc
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pypandoc/pypandoc-$pkgver.tar.gz"
builddir="$srcdir/pypandoc-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -22,7 +25,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pypandoc-*.whl
}
-sha512sums="511f5f5f7bff8de686c3f74d3756d27a3ae245803e2e9b45abc957acf112b306eff057ce87e8f3b335de00b97d4753de31e9681830d9aa776247ca707683ed13 pypandoc-1.5.tar.gz"
+sha512sums="
+b4b39fc94dea3ad45f8f33cff9e291ea2a9aa52aece5e092e5fdded4b95a9bf8c7047744d7fd6ec03dc53044a7261033deeec648a7d5530026580fc18ababdeb pypandoc-1.13.tar.gz
+"