aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyphen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyphen/APKBUILD')
-rw-r--r--testing/py3-pyphen/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/py3-pyphen/APKBUILD b/testing/py3-pyphen/APKBUILD
deleted file mode 100644
index a2ba75c1871..00000000000
--- a/testing/py3-pyphen/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py3-pyphen
-_pkgname=Pyphen
-pkgver=0.9.5
-pkgrel=3
-pkgdesc="python-based dictionary hyphenator library"
-url="https://www.pyphen.org"
-arch="noarch"
-license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-replaces="py-pyphen" # Backwards compatibility
-provides="py-pyphen=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- py.test-3 -v test.py
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="049a62b226e90e568c8f56e756f8fa6fbc74f3bc40d61af8eb05ff2d4404a7b29cef14d4f144d68ed2f2b11eb128491de64536240ba7b76a2d04010c76e10346 Pyphen-0.9.5.tar.gz"