aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyrebase/drop-requirements.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyrebase/drop-requirements.patch')
-rw-r--r--testing/py3-pyrebase/drop-requirements.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/py3-pyrebase/drop-requirements.patch b/testing/py3-pyrebase/drop-requirements.patch
new file mode 100644
index 00000000000..af0563f7381
--- /dev/null
+++ b/testing/py3-pyrebase/drop-requirements.patch
@@ -0,0 +1,18 @@
+Author: Rejah Rehim <rejah@beaglesecurity.com>
+Summary: Fixes dependency compilation error
+
+--- a/setup.py
++++ b/setup.py
+@@ -15,12 +15,4 @@
+ ],
+ keywords='Firebase',
+ packages=find_packages(exclude=['tests']),
+- install_requires=[
+- 'requests==2.11.1',
+- 'gcloud==0.17.0',
+- 'oauth2client==3.0.0',
+- 'requests_toolbelt==0.7.0',
+- 'python_jwt==2.0.1',
+- 'pycryptodome==3.4.3'
+- ]
+ )