aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyte/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyte/APKBUILD')
-rw-r--r--testing/py3-pyte/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py3-pyte/APKBUILD b/testing/py3-pyte/APKBUILD
index ccf1ebd3779..ff6f1505437 100644
--- a/testing/py3-pyte/APKBUILD
+++ b/testing/py3-pyte/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=py3-pyte
_pkgname=pyte
-pkgver=0.8.0
-pkgrel=2
+pkgver=0.8.2
+pkgrel=1
pkgdesc="Pyte is an in memory VTXXX-compatible terminal emulator"
url="https://github.com/selectel/pyte"
arch="noarch"
license="LGPL"
depends="py3-wcwidth"
makedepends="py3-setuptools py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="pyte-$pkgver.tar.gz::https://github.com/selectel/pyte/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,8 +23,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-
-sha512sums="c488fd0a61c1dc34b27e12ed9ba1109bb2c331626c982da06e7540bdd168008cb5106a17c71e60e38c493f2dd9f21ba3cf05118928744dfa192d62e511b4c4e8 pyte-0.8.0.tar.gz"
+sha512sums="
+e9e79babb81b32eedbb4f0585ef07f8978e8592171834d9ce43a09f8a1d3156c00abb535e887ba9c83909bf1010210009b9a00ccbec7c2e430e5147120949743 pyte-0.8.2.tar.gz
+"