aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pytest-flake8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pytest-flake8/APKBUILD')
-rw-r--r--testing/py3-pytest-flake8/APKBUILD28
1 files changed, 0 insertions, 28 deletions
diff --git a/testing/py3-pytest-flake8/APKBUILD b/testing/py3-pytest-flake8/APKBUILD
deleted file mode 100644
index 0e1862d9140..00000000000
--- a/testing/py3-pytest-flake8/APKBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py3-pytest-flake8
-_pyname=pytest-flake8
-pkgver=1.0.4
-pkgrel=2
-pkgdesc="pytest plugin for efficiently checking PEP8 compliance"
-url="https://pypi.org/project/pytest-flake8/"
-arch="noarch"
-license="BSD-3-Clause"
-depends="py3-pytest py3-flake8"
-makedepends="py3-setuptools"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="39ac19f3216386dc33b7c3c7c12a026751bb636d140340eb9585e161292d74f587c3a032125380bd12834e841172bf47652c19036bd06d493abd11cefe428429 pytest-flake8-1.0.4.tar.gz"