aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-python-archive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-python-archive/APKBUILD')
-rw-r--r--testing/py3-python-archive/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/py3-python-archive/APKBUILD b/testing/py3-python-archive/APKBUILD
index 3baa7da958f..29301b1f875 100644
--- a/testing/py3-python-archive/APKBUILD
+++ b/testing/py3-python-archive/APKBUILD
@@ -3,25 +3,25 @@
pkgname=py3-python-archive
_pkgname=python-archive
pkgver=0.2
-pkgrel=2
+pkgrel=5
pkgdesc="Library for extracting zip and tar archives"
url="https://github.com/gdub/python-archive"
arch="noarch"
license="MIT"
replaces="py-archive" # for backwards compatibility
provides="py-archive=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" # no tests
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="5f02fe522f44989c1b61db48239cdbda5536ff685174ba93af028591eba276dcefd7655aad3a458d92140f163724d87bbe25711c78a82e06dfb382b6ae9f5683 python-archive-0.2.tar.gz"