aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-python-logstash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-python-logstash/APKBUILD')
-rw-r--r--testing/py3-python-logstash/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-python-logstash/APKBUILD b/testing/py3-python-logstash/APKBUILD
new file mode 100644
index 00000000000..33aa634462b
--- /dev/null
+++ b/testing/py3-python-logstash/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rejah Rehim <rejah@beaglesecurity.com>
+# Maintainer: Rejah Rehim <rejah@beaglesecurity.com>
+pkgname=py3-python-logstash
+_pkgname=python-logstash
+pkgver=0.4.8
+pkgrel=3
+pkgdesc="Python logging handler for Logstash"
+options="!check" # no test suite
+url="https://github.com/vklochan/python-logstash"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+0ddc7e142f54aa27b0678fa903357ac877b755fb0ce3d8596472e843ca67c11d727289cebb5a0b4b4b613a768e8afde0ab4c0366305b7d9d5743fde8f1060e7a python-logstash-0.4.8.tar.gz
+"