aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-rabbit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-rabbit/APKBUILD')
-rw-r--r--testing/py3-rabbit/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-rabbit/APKBUILD b/testing/py3-rabbit/APKBUILD
index 7beb0995c21..01e2130e1a8 100644
--- a/testing/py3-rabbit/APKBUILD
+++ b/testing/py3-rabbit/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-rabbit
_pkgname=pyrabbit
pkgver=1.1.0
-pkgrel=3
+pkgrel=7
pkgdesc="Pythonic interface to the RabbitMQ Management HTTP API"
options="!check" # No testsuite in PYPI tarball
url="https://github.com/bkjones/pyrabbit"
@@ -11,6 +11,7 @@ arch="noarch"
license="MIT"
depends="python3 py3-httplib2"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,7 +23,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="aa18c3ad232840da9b4978e275c05a82ea75212f3c4ee2df68075ac93295d9448a2376656953e7d1d9c9bc6a7e759eef020a8aaef98491a12959a416c31187ad pyrabbit-1.1.0.tar.gz"