aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-requests-unixsocket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-requests-unixsocket/APKBUILD')
-rw-r--r--testing/py3-requests-unixsocket/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/testing/py3-requests-unixsocket/APKBUILD b/testing/py3-requests-unixsocket/APKBUILD
deleted file mode 100644
index 9b644196968..00000000000
--- a/testing/py3-requests-unixsocket/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Duncan Bellamy <dunk@denkimushi.com>
-# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
-pkgname=py3-requests-unixsocket
-pkgver=0.2.0
-pkgrel=0
-pkgdesc="Use requests to talk HTTP via a UNIX domain socket"
-url="https://github.com/msabramo/requests-unixsocket"
-arch="noarch"
-license="Apache-2.0"
-depends="py3-requests"
-makedepends="py3-pbr py3-setuptools"
-checkdepends="py3-pytest py3-waitress"
-source="https://files.pythonhosted.org/packages/source/r/requests-unixsocket/requests-unixsocket-$pkgver.tar.gz"
-builddir="$srcdir/requests-unixsocket-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- # pytest.ini specfies pep8 which is deprecated by codestyle
- rm test-requirements.txt pytest.ini
- python3 -m pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- # remove tests
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/requests_unixsocket/test*
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/requests_unixsocket/__pycache__/test*
-}
-
-sha512sums="a670f136ff1d8fb427cd017d92d388fd48a8a853d50aaa6eed685f3b453e28c6dbf5a710d7394face3eec42f8bdd84f798c7c4c82dab7b53d7a8c229ade52405 requests-unixsocket-0.2.0.tar.gz"