aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-rpio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-rpio/APKBUILD')
-rw-r--r--testing/py3-rpio/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-rpio/APKBUILD b/testing/py3-rpio/APKBUILD
index beeddbbff56..02262c9b6a2 100644
--- a/testing/py3-rpio/APKBUILD
+++ b/testing/py3-rpio/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-rpio
_pkgname=RPIO
pkgver=0.10.1
-pkgrel=3
+pkgrel=7
pkgdesc="GPIO toolbox for the Raspberry Pi"
options="!check" # No testsuite
url="https://github.com/metachris/RPIO"
arch="all"
license="LGPL-3.0-or-later"
makedepends="py3-setuptools python3-dev"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/metachris/RPIO/archive/v$pkgver.tar.gz
missing-typesh.patch"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,7 +23,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="47243abb5fa05a019e5de851035cf4d3e2d00b7ebb58fee86e3d89dc5ab4f4938c387d1824a721887a59706d0b401742c709ae53730f09cd021a224eddcd09c4 py3-rpio-0.10.1.tar.gz