aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-rtree/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-rtree/APKBUILD')
-rw-r--r--testing/py3-rtree/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/py3-rtree/APKBUILD b/testing/py3-rtree/APKBUILD
index fb575281ac3..52acba3565e 100644
--- a/testing/py3-rtree/APKBUILD
+++ b/testing/py3-rtree/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=py3-rtree
_pkgname=rtree
-pkgver=0.9.7
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="Python3 library for r-tree spatial index (wrapper for libspatialindex)"
url="https://pypi.org/project/Rtree/"
# s390x: Test failed: IndexSerialization::test_interleaving - AssertionError
# s390x: Test failed: IndexStream::test_stream_input - AssertionError
-# mips(64): numpy missing
-arch="noarch !s390x !mips !mips64"
+arch="noarch !s390x"
license="MIT"
depends="python3 libspatialindex-dev"
makedepends="py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-numpy"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/Toblerity/rtree/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -26,7 +26,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="f3add9440ddbc3b40366a3826c4206d03d46aa4e0e5cf90e5838347def7f9b52662458cb964a5f27cfd589637b2b1616dca62cbd89e6095601cf0f1881e2090b py3-rtree-0.9.7.tar.gz"
+sha512sums="
+97a87027e49520f12cb86444ee8a9795fabeec6d8f0e3e869f2714df8f7c649ced1374385852af0ce7d7eb91e5a2cb464a4330807be15d538dc0a4d8de7b7ca2 py3-rtree-1.1.0.tar.gz
+"