aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-scikit-uplift/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-scikit-uplift/APKBUILD')
-rw-r--r--testing/py3-scikit-uplift/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py3-scikit-uplift/APKBUILD b/testing/py3-scikit-uplift/APKBUILD
deleted file mode 100644
index 9aa05304da1..00000000000
--- a/testing/py3-scikit-uplift/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
-# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
-pkgname=py3-scikit-uplift
-_pkgorig=scikit-uplift
-pkgver=0.4.1
-pkgrel=0
-pkgdesc="Classic approaches of Uplift modelling in scikit-learn style in python"
-url="https://www.uplift-modeling.com"
-arch="noarch !s390x !riscv64 !x86 !armhf !armv7" # py3-scikit-learn, py3-matplotlib, memory errors
-license="MIT"
-depends="python3 py3-scikit-learn py3-numpy py3-pandas py3-matplotlib py3-requests py3-tqdm"
-checkdepends="python3-dev py3-pytest"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/scikit-uplift/scikit-uplift-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgorig-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 -m pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-5ff356dd9a3bce094a4b0cec15de13f8f0f0a5c25e528275790728781fa6d7d3bcb1bfb95663423012dd9a9e9aba2aacec0f48260a30254585e8df83eb4d0038 py3-scikit-uplift-0.4.1.tar.gz
-"