aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-seqdiag/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-seqdiag/APKBUILD')
-rw-r--r--testing/py3-seqdiag/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-seqdiag/APKBUILD b/testing/py3-seqdiag/APKBUILD
index b1a3558d4a2..f9b02c8b784 100644
--- a/testing/py3-seqdiag/APKBUILD
+++ b/testing/py3-seqdiag/APKBUILD
@@ -2,26 +2,32 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-seqdiag
_pkgname=seqdiag
-pkgver=2.0.0
-pkgrel=1
+pkgver=3.0.0
+pkgrel=4
pkgdesc="Generate sequence-diagram image file from spec-text file"
-url="https://pypi.python.org/pypi/seqdiag"
+url="https://pypi.org/project/seqdiag"
arch="noarch"
license="Apache-2.0"
depends="py3-funcparserlib py3-blockdiag py3-pillow"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-seqdiag" # for backwards compatibility
+replaces="py-seqdiag" # for backwards compatibility
provides="py-seqdiag=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="944fbacffefb496a3ac4959af7681122f686b9a5d4a019659128c8b999314e52860068474c67265c328f31fd3e750f3d2e3e7c633c50f5d4bcbe1880feb94804 seqdiag-2.0.0.tar.gz"
+sha512sums="
+b98a7056abc9941fe88fec5e58d07fa76b027d24204a0b072aa15690d557303589fb2bffed59f6be1b58c8bdadac9cac3e75e427e027bc815a82e97be9570e22 seqdiag-3.0.0.tar.gz
+"