aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-setuptools-git/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-setuptools-git/APKBUILD')
-rw-r--r--testing/py3-setuptools-git/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/py3-setuptools-git/APKBUILD b/testing/py3-setuptools-git/APKBUILD
deleted file mode 100644
index 92095bd41a6..00000000000
--- a/testing/py3-setuptools-git/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-setuptools-git
-_pkgname=setuptools-git
-pkgver=1.2
-pkgrel=3
-pkgdesc="Setuptools plugin for Git"
-url="https://github.com/wichert/setuptools-git"
-arch="noarch"
-license="BSD-3-Clause"
-replaces="py-setuptools-git" # for backwards compatibility
-provides="py-setuptools-git=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3 git"
-makedepends="python3-dev py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- export EMAIL="Test User <user@example.com>"
- python3 setup.py test
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="c070911618b6b92c862fb0bd40f1daeaf79e2ba10389fa1e69e4c50cfdd39c8e57a612082cbc7d932f8cea12a769e13451e35e1c8fe34f170d4817fd0d44f156 setuptools-git-1.2.tar.gz"