aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-setuptools-lint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-setuptools-lint/APKBUILD')
-rw-r--r--testing/py3-setuptools-lint/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-setuptools-lint/APKBUILD b/testing/py3-setuptools-lint/APKBUILD
index 2ef8829a03d..2c6b82cd42a 100644
--- a/testing/py3-setuptools-lint/APKBUILD
+++ b/testing/py3-setuptools-lint/APKBUILD
@@ -2,25 +2,31 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-setuptools-lint
pkgver=0.6.0
-pkgrel=2
-pkgdesc="Setuptools plugin for Git"
+pkgrel=9
+pkgdesc="Expose pylint as a lint command into setup.py"
url="https://github.com/johnnoone/setuptools-pylint"
arch="noarch"
license="BSD"
-depends="python3"
-makedepends="py3-setuptools"
+depends="py3-setuptools"
+makedepends="py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/s/setuptools-lint/setuptools-lint-$pkgver.tar.gz"
builddir="$srcdir"/setuptools-lint-$pkgver
-replaces="py-setuptools-lint" # Backwards compatibility
+replaces="py-setuptools-lint" # Backwards compatibility
provides="py-setuptools-lint=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="d36c10bab45672b3c7d92391c8f1ae297a483500654e8b31a312587c9d9355a74beddb466ea952fa4cc8bc035c4f631536eeefd61ae159f807767f61fabc72d4 setuptools-lint-0.6.0.tar.gz"
+sha512sums="
+d36c10bab45672b3c7d92391c8f1ae297a483500654e8b31a312587c9d9355a74beddb466ea952fa4cc8bc035c4f631536eeefd61ae159f807767f61fabc72d4 setuptools-lint-0.6.0.tar.gz
+"