aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sh/APKBUILD')
-rw-r--r--testing/py3-sh/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/testing/py3-sh/APKBUILD b/testing/py3-sh/APKBUILD
index 478cc2be9f5..6edfd555b39 100644
--- a/testing/py3-sh/APKBUILD
+++ b/testing/py3-sh/APKBUILD
@@ -2,32 +2,36 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-sh
_pyname=sh
-pkgver=1.14.2
-pkgrel=0
+pkgver=2.0.6
+pkgrel=1
pkgdesc="Python subprocess replacement"
-url="https://amoffat.github.io/sh/"
+url="https://sh.readthedocs.io/"
license="MIT"
-arch="noarch !x86 !armv7" # test_custom_timeout_signal fails on x86 and armv7
-options="!check" # tests fail on the builders
+arch="noarch"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-poetry-core"
checkdepends="py3-pytest lsof coreutils"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/s/sh/sh-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD"/build/lib pytest test.py \
- --deselect test.py::MiscTests::test_no_fd_leak # skip unreliable test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-b7917504ae85606e1986b681274077777ad3011639bfe933d4133c3ed16f930842e03b572caa396ca4d58f41fd5594bef776cc16c4b0fbd1242e57c6aad19e62 py3-sh-1.14.2.tar.gz
+717dae58ebd08b3a86e0d30ba2a6f3055592844d064265280b97a1d29bd7d0422c9e5500b6eb999cc1a97c1c2af04cf8ed214670bc08cb2bc45e418f69560c1d py3-sh-2.0.6.tar.gz
"